2015/01/28

Windows 10 TPのインストール時のエラー

Windows 10 TPのインストール時に遭遇したエラーについての記録。

1. エラーの状況

最近のWindowsのインストールで問題が出ることはあまりないですが、久々に謎なエラーに遭遇しました。前提として、UEFI Onlyに設定したThinkPad X230でUEFI用に作成したUSBメモリから起動してのインストールです。

状況としては、
  1. Build 9926の日本語版のISOファイルからUSBメモリを作成し、これから起動しようとしたところ、「お使いのPCに必要なメディアドライバーがありません。」というエラーが表示されて進めない。


  2. IntelのIRSTのドライバーファイルを読み込ませてみたが、変化なし。たぶんこのメッセージどおりの問題ではない。
  3. ISOファイルのハッシュ値を確認したが、ダウンロードサイトに示されたとおり。
  4. USBメモリを作成し直してみたが、エラーは変わらず。そもそもUEFI用のUSBメモリの作成方法は簡単で(後述)、間違う余地は少ない。
  5. 英語版のISOファイルからUSBメモリを作成してみたが、"A media driver your computer needs is missing."という同内容のエラーが出る。


  6. 単純な問題ではない気配がしてきたので、ISOファイルをDVD-Rに焼いてインストールしたところ、問題なく終了。問題はUSBメモリの起動にある。
  7. 残しておいたBuild 9879のISOファイルからUSBメモリを作成してみたが、エラーは変わらず。Build 9926特有の問題ではないが、しかし以前は問題なかったはず。
  8. ふとUSBメモリを差すコネクタをX230の向かって左側から右側に変えたところ、エラーは出ず、ハードウェアと関係があることが判明。正確には左側2箇所のコネクタ(USB.3.0)のどちらでもエラーが出るが、右側1箇所のコネクタ(USB2.0)では出ない。なお、左側でも通常時は問題ないし、左側で作成したUSBメモリで右側から起動もできる。
  9. 確認のため、USBメモリをそれまでのPicoDrive F3 32GBから、Express RC8 25GBとJetFlash 760 16GB(いずれもUSB3.0)に変えてみたが、エラーの出る条件は変わらず。USBメモリ側の問題ではない。
  10. さらに確認のため、USBメモリをPicoBoost 8GB(USB 2.0)に変えてみたところ、左右どちらでもエラーは出ず。エラーが出るのはUSB3.0の場合のみ。
  11. 念のため、Windows 8.1 Enterprise評価版のISOファイルを使ってみたところ、USB3.0のUSBメモリでも左右どちらでもエラーは出ず。エラーが出るのはWindows 10 TPの場合と判明。
以上をまとめると、
  • X230の左側のUSBコネクタ(USB3.0)
  • USB 3.0のUSBメモリから
  • Windows 10 TPのインストーラーを起動
しようとした場合にこのエラーが出る、ということになります。

真っ先に疑われるのはX230のUSBコネクタの劣化あるいは埃詰まりで、通常時には問題ないものがインストール時に顕在化するというのは昔からあることですが、
  • 製造から1年足らずで、2箇所のコネクタに同じ問題が出るものか。
  • USB3.0用のメス側の接点はベロの先端に、かつX230の場合は下向きに付いているので、埃は付着しにくい。
ということがあって、保留です。

一つ明らかなのは、Windows 10 TPのインストーラーはUSB3.0の認識に何か変更があったっぽい、ということですが、まあ問題に遭遇でもしない限り無駄知識ですけど。

[追記1]

コメントいただいた情報によればX1 CarbonのUSB3.0コネクタでも同じエラーが出るそうで、かつX230の右側のコネクタはUSB2.0なので、エラーが出る条件としてはUSB3.0がやはりキーのようです。

[追記2]

Microsoft CommunityのWindows Insider Programにポストしました。
[追記3]

Insider PreviewのBuild 10074のISOではこのエラーは出なくなりました(日本語版、英語版とも)。問題は解決されたようです。

2. UEFI用のUSBメモリの作成

なお、UEFIではブートに関するノウハウが従来と変わりました。パーティションがアクティブであること、専用のブートセクタであることは必要なくなりました。代わりにパーティションがFAT32であることが必須です。

したがってブータブルなUSBメモリを作成するには、とにかくFAT32でフォーマットして、ISOファイル(x64版であること)の中身をコピーするだけです。特別なツールやDiskPartを使う場面は基本的にないと思います。

この点に関して、Microsoftの高橋さんが書かれている方法のうちアクティブとブートセクタの部分は、従来の場合と両対応にするために必要なことであって、UEFIだけ考える場合は必要ないと思います。

6 コメント :

匿名 さんのコメント...

ThinkPad X1 Carbonを使用しており、このエラーに悩まされていました。まさか、USB 3.0が原因だったとは。

右側のUSB 3.0コネクタから、左側のUSBコネクタに変更したところ、何の問題もなくインストールが完了しました。

この記事に助けられました。ありがとうございました。

EMO さんのコメント...

情報ありがとうございます。同じ事例があるということは、PC本体の問題でもなさそうですね。

改めてX230の右側のコネクタを見たらUSB2.0でした。ということは条件を絞り込めそうなので、本文を修正します。

匿名 さんのコメント...

貴重な情報有り難うございます
当方もx230でUSB3.0だけbootできない症状であちこち探している最中です。
linuxのisoをusb3.0メモリに作成し右側のusb2.0にさして、左奥側のusb3.0ポートにusb3.0メモリfat32フォーマット済みをさしてそこにインストールしたのですが1回だけ立ち上がったのですがその後bootできずでusb2.0に差し替えて普通にbootしてます。どうにかusb3.0でと思うのですが。。。。。。

EMO さんのコメント...

X230のお仲間ですね。新しいBuildのISOが出たら試そうと思ってますが、まだ出ませんね。

匿名 さんのコメント...

拝読させていただきました。ASUSのUX32VDで、Windows7SP1インストール時にこの問題に出くわしました。この機種はUSBポートが全て3.0で、DVDドライブも内蔵せず、SDカードスロットもドライバを入れるまでは認識しないので、途方に暮れました。結局他のノートにインストールして、レジストリを書き換えてHDDを移植しました。8.1では起きない問題なんですね…。10の製品版ではUSB3.0にも標準ドライバが用意されるといいのですが。

EMO さんのコメント...

たぶんUSB3.0のドライバというよりISOの起動環境の何かがおかしいのだろうと思いますが、正確なところは分からないです。